Service News

Changes to our Email for Life Security Regarding Email Clients

Due to recent updates to the security settings of our Email for Life servers, some users may have noticed that their emails via an email client (Outlook, Thunderbird, etc.) were not accessible. In many cases, this is due to the age of the email client being used as some older email clients do not support a level of security that is now required.
 
To allow affected users to be able to access their emails, we will shortly be reverting some of the recent security changes to allow older email clients to continuing accessing emails. Please note this change will only be in place for the next three months. We would urge all of our Email for Life customers to update your operating systems and email clients to the latest versions to guarantee future compatibility.
 
As a guide, the following email client versions and later should be considered the minimum requirements:
 
Outlook 2003 on Windows 8.1
Outlook 2016 on OSX 10.11
MacMail on OSX 10.12
Mail on iOS 11
Mail on Android 5
 
For the technical among you, as long as your email client supports TLS version 1.2 you should see no disruption to your service via an email client.
 
Thank you.

Originally Written: 10-May-2022 17:46, Last Updated: 10-May-2022 21:05

More Service News

Service News
Updated 10 days ago

Last Post:
Changes to our Email for Life Security Regarding Email Clients